[ad_1]

Trying to install filebazaar on Ubuntu 18.04 and getting an error on the canvas module… anyone familiar with this issue? I’ve been all over node-canvas’s github issues (such as this one where I left a comment), but none of the solutions are working for me so far.

Here’s the command I’m running:

$ sudo npm install -g filebazaar

And here’s the error output:

$ sudo npm install -g [email protected]

> [email protected] install /usr/local/lib/node_modules/canvas
> node-gyp rebuild

gyp ERR! configure error 
gyp ERR! stack Error: EACCES: permission denied, mkdir '/usr/local/lib/node_modules/canvas/build'
gyp ERR! System Linux 4.15.0-55-generic
gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/canvas
gyp ERR! node -v v12.5.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! [email protected] install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the [email protected] install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/chris/.npm/_logs/2019-09-17T20_39_13_514Z-debug.log

Any assistance is appreciated 🙂

[ad_2]

Source link

By admin

Leave a Reply

Your email address will not be published. Required fields are marked *